EIGRP and eigrp authentication

router eigrp 1

no auto-summary

passive-interface default

no passive-interface f0/0

no passive-interface f1/0

eigrp router-id 1.1.1.1

network 10.0.0.0

sh ip eigrp nei

 

 

EIGRP Authentication

 

secures routing protocol communication

prevent route poisening

 

key chain EIGRP

key 1

key-string cisco

exit

exit

int f0/0

ip authentication key-chain eigrp 1 EIGRP

ip authentication mode eigrp 1 md5

ip authentication key-chain eigrp 1 md5

have to set it up on all the routers becuase the routes will go down

got to do it on the other routers

 

 

 

 

 

IPv4 and IPv6 – most boring topic ever

Unicast Multiccast Broadcast

one to one, one to many, one to all

VLSM – variable length subnet mask for different subnets

Supported Routing Protocol EIGRP OSPF RIPv2 BGP ISIS

RIPv1 and IGRP does not

 

ARP: Protocol used to discover mac address to IP address mappings

DHCP: Discover Offer Request ACK

 

IPv6 Addressing

Golobal Unicast – 2000::/3

48 16 subnet prefix

64 bits host address

Router 1

config t

ipv6 unicast-routing

int f0/0

ipv6 address 2001::1/64

int f1/1

ipv6 address 2001:1::1/64

exit

ipv6 route 2001:2::/64 2001::2

do show ipv6 int brief (to verify)

 

Router 2

config t

ipv6 unicast-routing

int f0/0

ipv6 address 2001::1/64

exit

ipv6 route 2001:1::/64

 

[pc1] — [r1]—–[r2]–[pc2]

ping pc1 from pc2

can ping

 

eui 64 generated host address based on MAC address value

if you enable ipv6 on router link local address will be generated.

 

layer 2 addressing

ipv6 nd neighbor discovery

host to host

message sent to a remote host asking for link layer address is neighbor advertisement

host to router

host router solicitation rs message sent to discover routers on local link

router advertisement message to a router solicitation with network router information

ipv6 dhcp

stateful or stateless dhcp

stateful

solicit advertise request reply

stateless slaac host use icmpv6 message to discover prefix info

router solicitation router advertisement

 

 

Frame Relay

Legacy Layer 2 Wan Encapsulation

DTE: data terminal equipment

DCE: data circuit terminal equipment

PVC: permanent virtual circuit – logical connection in frame relay network

DLCI: Data-link connection identifier – local identifier for each PVC

LMI – local management interface – signaling standard used to exchange information

DTE

[R1]

L

M

I

DTE[R2]     <–LMI–>               DCE Frame         <–LMI–>               DTE[R3]

Relay Switch

 

Point to Point OSPF 10 sec

Point to Multipoint OSPF 30 sec

 

PPPoe

PPPoe is point to point protocol over Ethernet

 

interface f0/0

no shut

no ip address

pppoe enable

pppoe-client dial-pool-number 1

interface dialer1

ip address negotiated  (IPCP is like dhcp)

mtu 1492 (8 bytes overhead)

encapsulation ppp

dialer pool 1

dialer persistent (maintains connection)

 

pppoe client (f0/0) ________________WAN ________________     pppoe server

[r1]                   ________________WAN________________     [R2]

 

pap and chap works here too

 

 

 

PPP – my notes prob not make sense

HDLC to PPP

 

show int s2/0

Encap HDLC

 

config t

int s2/0

encap ppp

 

ping 10.1.2.2

reply

 

encap ppp

ppp pap sent-username R1 password Cisco

Username R2 password Cisco

 

r1 username R2 password Cisco

interface s2/0

ppp authentication pap

ppp pap sent-username R1 password Cisco

 

shut

no shut

 

se2/0 is up

 

 

 

debug ppp negotiation

debut ppp negotation

shut

no shut

 

see negotation ppp after that

 

 

CEF, FIB,TCP, ICMP – review

CEF optimizes route processing. Improves performance.

Fast switching and route caching  FIB table next hop IP info

Review

Unicast 0.0.0.0 – 223.255.255.255

Multicast 224.0.0.0 – 239.255.255.255

Out of Order Packets.

TCP has preventative measures like sequencing and re-transmission.

Asymmetrical Routing may have issues if mtu is different and if it is not identical.

ICMP unreachable – generated by a router to inform source host that it receives packet that destination is unreachable.

ICMP redirects – generated by a router to inform source host that it should send packets to another router to improve performance

TCP Latency – time delay required for info to travel accross network

Windowing amount of unacknowledged data that can be transmitted.

 

The Final Stretch / My Test Experience

The day before my exam, I did a packet tracer lab. This helped me so much to reinforce the knowledge for the exam. The “Best cram sheet” pdf from my last post also was a major help.

L3 diagramphysical diagram

instructions

I configured this on Packet Tracer and it felt like supercharging my confidence in taking the exam.

Here is what I can say about the exam:

They are super tricky with the wording, so read every word.

Sometimes there are multiple answers that sound correct, and a process of elimination is  a required method.

There are some configuration questions, don’t waste your time double and triple checking you will waste your time. It is a timed test.

Don’t second guess yourself.

And the obvious and most forgotten: Get a good night sleep, eat a good breakfast, don’t stress, focus. And if you eat chocolate to calm your nerves…

Don’t take the pic with chocolate in your mouth. The pic will haunt you!!!!

 

foodinmouth

 

It was worth the pass though!

https://www.youracclaim.com/badges/01bad338-eb5e-4797-b5f8-db59fd6af635

acclaim

 

Oh and this is nifty

ccna

 

So here’s a question! What is the funnest thing about the subject matter in the CCNA exam?

Routers, Switches, Hosts, Cables. They are all beasts.

Everything else is the study of the mannerisms, communication, rules and hierarchies that goes on between them.

They are well trained, you just have to learn how to talk to them. Configuration is not too bad as long as you know what mode to be in, what you want to do,  and make use of question mark and tab.

Cables are like children that like to have fun.

It is so much fun to personify it.

It’s fun to apply some of this stuff to real life. TCP when communicating.

I was getting my hair highlighted the day before my exam. I spent like two hours trying to explain CCNA to the hair dresser. She was fascinated and told her son to look into CCNA.

Immediate Goals: Become more immersed with Networking on the job. Then, to be the person who implements the network design. Then I would be able to get enough experience to be the person actually creating the network design for customers.

Eventually… One of these days, when I am way more experienced, and I can call myself an expert, I will absolutely enjoy teaching this stuff. There will be lots of funny voices and personification involved. BEAST MASTER TRAINING!

 

 

My Loose Direction in Life

Today, I was talking to my best friend. He works three jobs and will always make the time to help his friends in need. I’ve never met a more heroic and hardworking person in my life. I swear, I don’t know how I would have gotten through so many difficult moments in my life, if it wasn’t for my bestest best friend. We have so many awesome fun times as well. He is like a delicious seasoning for life if it was a food.

I asked him why he works so hard, and what motivates him to do that, and is he taking the time to develop himself. He is a very goals oriented person. He is working hard for a better future, for his dream home on the beach and easy retirement. Then he asked me the same questions…

I could not answer immediately, it took some moments of thought to articulate exactly what I wanted to say. The background is, I hate my job, but it is the job that I need in my life, not the job that I want. Even my boss says that it is sucking the creative soul right out of me.To be honest, I had a job that I woke up every day and enjoyed going to. It was the worst thing to ever happen in my life because I was complacent and stagnant for years. I would never grow as a person if I stayed there. Getting laid off was the best thing that ever happened to me. But why, is it, that the job I’m doing now, that I hate, is the best thing for me?

Some days, I feel like going to work is a waste of time. It really takes away all the family time that I have and gives me crumbs of moments with my family if I try not to rob them of sleep or their work times. I try to keep this job in particular because it gives me a lot of time for myself. I use this time to grind. I use it to study, to reflect, look at my options and grow. It helps me keep my car, have fun, make memories, and think about the options I will have later.

So why am I studying CCNA? It is a tried and true certification that will boost your income. It is also very interesting. It is the most fun thing to personify and imagine as beasts, animals and aliens that are trying to understand manners and communication with each other successfully. If you think about it like that you will laugh a lot throughout your study journey.

What is my motivation for a boost in income? What’s my long term goal in terms of career? What are my big purchases goals? I am trying to get myself in the financial place where I will be able to secure the funds to open and grow the Fierce Women’s Fitness business. To develop this stepping stone into a spectacular arena with beautiful and inspirational performances. I want to be able to treat myself and take care of myself as the beautiful woman that I am. Get my hair, nails, face done, get a spa treatment, without feeling guilt. I want to be a Harley-Davidson rider again. I bought my dream car, I want to customize it. I want to develop my dance, aerial silks, pole, and martial arts skills. I want to be the owner of a beautiful Maronda Trinity Home. I want to overcompensate my femininity to make up for the fact that I have PCOS. I want to be the best damn provider and parent to ever exist.

I have always been a goals oriented person and a giver. I have struggled to find a balance between the two. My nature is to take care of other people before taking care of myself. I have given my heart to a man who has the same goals-oriented mindset as myself who has found that balance. He is ahead of me by far. He is genuine, sincere, loving and smart. He tries to be the best at everything. He has opened up my competitive nature and ego to the max. I love him a lot, but I refuse to live in the shadows of him and his success or have my accomplishments/hard work be falsely accredited to him. He likes this about me. I have always been an independent woman who’s life motto has been, “Every day getting better and better in every way,”