BGP peers,timers, authentication

BGP Globally Unique (public) AS# Range 1-64511

BGP Private AS# Range 64512 – 65535

router bgp (as can’t be previously used)

router bgp 650002

bgp router-id 1.1.1.1

neighbor 10.1.2.2 remote-as 65002

then configure on the other

 

next router

 

router bgp 65002

bgp router-id 2.2.2.2

neighbor 10.1.2.1 remote-as 65001

neighbor 10.2.3.2 remote-as 65002

 

verify

sh ip bgp sum

 

 

OSPF for IPv6

ipv6 router ospf 1

router-id 1.1.1.1

exit

int f0/0

ipv6 ospf 1 area 0

int f1/0

ipv6 ospf 1 area 0

 

do the same thing pretty much on the other routers change router-id

sh ipv6 ospf inter bri

 

 

OSPF Path Preference

Path Preference

1 Intra-Area (O) – routes learned from the same area

2 Inter-area (O IA) – routes learned from a different area

3 External Type 1 (E1) – routes learned from outside OSPF marked as E1

4 External Type 2 (E2) – routes learend outside of OSPF marked as E2

5 NSSA Type 1 (N1) –  routes learned from a NSSA area marked as N1

6 NSSA Type 2 (N2) – routes learned from a NSSA area marked as N2

sh ip route ospf

 

router ospf path types.PNG

LSA Types

LSA

1 router lsa router link advertisements within an area

2 network lsa  dr link advertsiements within an area

3 summary lsa abr network advertisements between areas

4 summary abr network advertisements between areas

5 external lsa asbr edternal route advertsiements

6 multacast lsa multicast advertsiements

7 nssa external lsa nssa asbr external route advertsiemetns

8 external attribute lsa for bgp bgp advertsiements

9-11 opaque lsa for future use

 

 

OSPF Network Types

point to point

dynamic 10

no dr bdr

 

multipoint

manual 30

no dr bdr

 

broadcast

dynamic 10

dr bdr

 

nonbroadcast

manual 30

dr bdr

 

router types

 

internal routers conencted to the same area

backbone routers routers connected to area 0

area border router abr routers connected to multiple areas

autonomous systems border router asbr routers conencted to segmetns external to ospf

 

 

OSPF Authentication

int f0/0

ip ospf message-digest-key or authentication-key

ip ospf message-digest-key 1 md5 cisco

ip ospf authentication message-digest

int f1/0

ip ospf message-digest-key 1 md5 cisco

ip ospf authentication message-digest

 

router ospf 1

area 0 authentication message-digest

 

 

 

OSPF Review

 

 

 

router id 1.1.1.1

router ospf 1

(process id is 1)

 

passive-interface default

no passive-interfcace f0/0

no passive-interfcace f1/0

network 10.0.0.0 0.255.255.255 area 0

 

sh ip ospf int  brief

 

make template copy paste with different router ids

 

sh ip ospf nei

 

EIGRP Path Preference and Load Balancing

Bandwidth and Delay

Metric Value – bandwidth, load, delay, reliability, mtu

default is bandwidth and delay

 

config t

ip route 0.0.0.0 0.0.0.0 1.1.1.1 name default-route

show run | i  0.0.0

router eigrp

red static

 

sh ip eigrp topo

(all paths even if not showed in routing table)

Feasible successor is a path whos reported distance is less than the feasible distance and it is considered a backup route. Eigrp will keep up to six feasible successors in the topology table. Only the one with the best metric the successor is placed in the routing table.

Equal cost load balancing and unequal cost load balancing

EIGRP provides a mechanism to laod balance over unequal cost paths through varience command. Varience is a number 1 to 128 multiplied by the local bes tmetric then includes the routes with the lessor or equal metric. The default varience value is 1 which means equal-cost load balancing

EIGRP Stub

router eigrp1

no passive-interface f1/1

router eigrp 1

no auto-summary

passive-itnerface default

no passive-interface f0/1

eigrp stub

sh ip eigrp nei

 

 

 

suppressing queries

 

without license advance routing, it could cause issues

 

EIGRP for IPV6

 

ipv6 unicast-routing

ipv6 router eigrp 1

(define router id)

eigrp router-id 1.1.1.1

 

do that on the other devices too

 

show ipv6 eigrp inter

 

make template, copy paste

 

 

 

 

EIGRP and eigrp authentication

router eigrp 1

no auto-summary

passive-interface default

no passive-interface f0/0

no passive-interface f1/0

eigrp router-id 1.1.1.1

network 10.0.0.0

sh ip eigrp nei

 

 

EIGRP Authentication

 

secures routing protocol communication

prevent route poisening

 

key chain EIGRP

key 1

key-string cisco

exit

exit

int f0/0

ip authentication key-chain eigrp 1 EIGRP

ip authentication mode eigrp 1 md5

ip authentication key-chain eigrp 1 md5

have to set it up on all the routers becuase the routes will go down

got to do it on the other routers