EIGRP and eigrp authentication

router eigrp 1

no auto-summary

passive-interface default

no passive-interface f0/0

no passive-interface f1/0

eigrp router-id 1.1.1.1

network 10.0.0.0

sh ip eigrp nei

 

 

EIGRP Authentication

 

secures routing protocol communication

prevent route poisening

 

key chain EIGRP

key 1

key-string cisco

exit

exit

int f0/0

ip authentication key-chain eigrp 1 EIGRP

ip authentication mode eigrp 1 md5

ip authentication key-chain eigrp 1 md5

have to set it up on all the routers becuase the routes will go down

got to do it on the other routers

 

 

 

 

 

IPv4 and IPv6 – most boring topic ever

Unicast Multiccast Broadcast

one to one, one to many, one to all

VLSM – variable length subnet mask for different subnets

Supported Routing Protocol EIGRP OSPF RIPv2 BGP ISIS

RIPv1 and IGRP does not

 

ARP: Protocol used to discover mac address to IP address mappings

DHCP: Discover Offer Request ACK

 

IPv6 Addressing

Golobal Unicast – 2000::/3

48 16 subnet prefix

64 bits host address

Router 1

config t

ipv6 unicast-routing

int f0/0

ipv6 address 2001::1/64

int f1/1

ipv6 address 2001:1::1/64

exit

ipv6 route 2001:2::/64 2001::2

do show ipv6 int brief (to verify)

 

Router 2

config t

ipv6 unicast-routing

int f0/0

ipv6 address 2001::1/64

exit

ipv6 route 2001:1::/64

 

[pc1] — [r1]—–[r2]–[pc2]

ping pc1 from pc2

can ping

 

eui 64 generated host address based on MAC address value

if you enable ipv6 on router link local address will be generated.

 

layer 2 addressing

ipv6 nd neighbor discovery

host to host

message sent to a remote host asking for link layer address is neighbor advertisement

host to router

host router solicitation rs message sent to discover routers on local link

router advertisement message to a router solicitation with network router information

ipv6 dhcp

stateful or stateless dhcp

stateful

solicit advertise request reply

stateless slaac host use icmpv6 message to discover prefix info

router solicitation router advertisement

 

 

Frame Relay

Legacy Layer 2 Wan Encapsulation

DTE: data terminal equipment

DCE: data circuit terminal equipment

PVC: permanent virtual circuit – logical connection in frame relay network

DLCI: Data-link connection identifier – local identifier for each PVC

LMI – local management interface – signaling standard used to exchange information

DTE

[R1]

L

M

I

DTE[R2]     <–LMI–>               DCE Frame         <–LMI–>               DTE[R3]

Relay Switch

 

Point to Point OSPF 10 sec

Point to Multipoint OSPF 30 sec

 

PPPoe

PPPoe is point to point protocol over Ethernet

 

interface f0/0

no shut

no ip address

pppoe enable

pppoe-client dial-pool-number 1

interface dialer1

ip address negotiated  (IPCP is like dhcp)

mtu 1492 (8 bytes overhead)

encapsulation ppp

dialer pool 1

dialer persistent (maintains connection)

 

pppoe client (f0/0) ________________WAN ________________     pppoe server

[r1]                   ________________WAN________________     [R2]

 

pap and chap works here too

 

 

 

PPP – my notes prob not make sense

HDLC to PPP

 

show int s2/0

Encap HDLC

 

config t

int s2/0

encap ppp

 

ping 10.1.2.2

reply

 

encap ppp

ppp pap sent-username R1 password Cisco

Username R2 password Cisco

 

r1 username R2 password Cisco

interface s2/0

ppp authentication pap

ppp pap sent-username R1 password Cisco

 

shut

no shut

 

se2/0 is up

 

 

 

debug ppp negotiation

debut ppp negotation

shut

no shut

 

see negotation ppp after that

 

 

CEF, FIB,TCP, ICMP – review

CEF optimizes route processing. Improves performance.

Fast switching and route caching  FIB table next hop IP info

Review

Unicast 0.0.0.0 – 223.255.255.255

Multicast 224.0.0.0 – 239.255.255.255

Out of Order Packets.

TCP has preventative measures like sequencing and re-transmission.

Asymmetrical Routing may have issues if mtu is different and if it is not identical.

ICMP unreachable – generated by a router to inform source host that it receives packet that destination is unreachable.

ICMP redirects – generated by a router to inform source host that it should send packets to another router to improve performance

TCP Latency – time delay required for info to travel accross network

Windowing amount of unacknowledged data that can be transmitted.